Please login or register. 2019-09-19, 10:12:31

Author Topic: Dveji skirtingų versijų Blender'iai Ubuntu OS  (Read 4791 times)

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Dveji skirtingų versijų Blender'iai Ubuntu OS
« on: 2014-07-25, 20:57:20 »
   Į Ubuntu 14.04 LTS įsidiegiau nuajausią Blender'į pagal šias instrukcijas, kitais būdais (atsisiuntus iš blender.org archyvą), niekaip nepavyko, bet dabar ne apie tai. Viskas, kaip ir gerai, bet neseniai radau (man šiuo metu aktualų) neoficialų Blender 2.69 build'ą, kuris palaiko layer'ius Texture Paint rėžime. Taigi kilo toksai klausimas: ar galima Ubuntu OS naudoti dvejus, skirtingų versijų (pireš tai, kurios nors iš jų, neišdiegus) Blender'ius? Jeigu tai įmanoma, tai gal galit mestelti kokią nors nuorodą į šio sprendimo būdą? Pačiam rasti nepavyko. Windows'uose tai labai paprastai išsprendžiama.

Ramūnas

  • Administrator
  • Šnekus
  • *****
  • Posts: 129
    • Blender.lt
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #1 on: 2014-07-26, 11:58:28 »
Blenderio diegimas labai paprastas - atsisiunti savos sistemai tinkamą versiją (dažniausiai užtenka OS ir 32/64bit). Išarchyvuok. Paleisk „blender“ failą iš naujo katalogo. Turi veikti visos turimos versijos.
Jei įdiegei blender per ubuntu paketų sistemą - jis tau netrukdo, tik paprastai terminale parašius „blender“ paleist versiją, įdiegtą su ubuntu. Parsiųstai versijojai gali rašyti „./blender“ būdamas jo kataloge ir paleisi naują. Šitie niuansai galioja tik naudojantis terminalu (komandine eilute). Paprasčiausia paleisti tiesiog spaudžiant pele ant „blender“ naujame kataloge. O jei nepasileidžia, tada terminalas išduos nepasileidimo priežastį.

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #2 on: 2014-07-27, 10:53:08 »
   Jokiais būdais gyvatė pasileisti nenori  :) . Išarchyvuotame atskirame aplanke spaudžiant ant blender išmeta pranešimą Nepavyko parodyti "blender". Neįdiegta programa vykdomasis failas failams. Na, o jeigu to failo savybėse (leidimų skiltyje) uždedu varnelę ant Leisti vykdyti failą kaip programą - iš viso nieko nevyksta.
   Na, o bandant paleisti per terminalą (Ctrl+Alt+T), kai varnelė minėtoje vietoje neuždėta, išmeta Permission denied. O, kai uždėta - error while loading shared libraries: libpython3.3m.so.1.0: cannot open shared object file: No such file or directory.
   Man atrodo, jog "dašuto" kame "šaknys". Spėju tame, kad kompas, kuriame yra Ubuntu, neprijungtas prie interneto. Žinoma, kai siunčiausi Ubuntu naujinius ir Blender'į (per Ubuntu paketų sistemą), dėžę buvau nusinešęs į kitą kambarį ir prisijungęs. Na, o kitus Blender'io build'us siunčiausi jau į laptop'ą su Wi-Fi, kuriame yra 32bit XP. Vat, manau, šitai ir "pakišo koją" (failai buvo atsisiųsti ir išarchyvuoti NTFS terpėje, po to kopijuoti į EXT4) - pasikeitė failo, keliavusio per skirtingo formato terpes, savybės.
   Taigi vėl reiks nešti dėžę prie interneto kabelio ir viską atsisiųsti bei įdiegti jau Ubuntu aplinkoje - sužinosiu ar esu teisus.
« Last Edit: 2014-07-27, 10:56:48 by {Giedrius} »

Kilgoras Trautas

  • Žaliukas
  • *
  • Posts: 30
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #3 on: 2014-07-27, 12:28:29 »
error while loading shared libraries: libpython3.3m.so.1.0: cannot open shared object file: No such file or directory
1. pas tave nera įdiegta "python 3"
2. blender neranda įdiegto "python 3"
labiausiai tikėtinas 1 variantas nuo jo ir pradėkime
atsidarai terminala ir rasai:
# sudo apt-get install python3-all
« Last Edit: 2014-07-27, 12:30:19 by Kilgoras Trautas »

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #4 on: 2014-07-27, 13:28:45 »
   Supratau, dėkui abiems už atsakymus  :) .
   Pasižiūrėjau, pas mane įdiegtas Python v3.4, o prašo (kaip suprantu) v3.3. Žodžiu, pasibandysiu ir šį variantą, bet, irgi, kai dėžę prijungsiu prie interneto, nes šiai komandai pastarasis taip pat reikalingas. Deja tai padarysiu tik rytoj - šiandien tam nėra sąlygų. Aišku, parašysiu kaip sekėsi  :) .

Kilgoras Trautas

  • Žaliukas
  • *
  • Posts: 30
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #5 on: 2014-07-27, 16:37:28 »
Tuomet tau reikės pridėti neoficialų, papildomą šaltinį.
gali pasinaudoti šia nuoroda http://ubuntuhandbook.org/index.php/2014/05/install-python-3-3-5-or-3-4-via-ppa-in-ubuntu-14-04-12-04/

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #6 on: 2014-07-30, 20:39:10 »
   Na ką, atsiradus laisvam laikui, toliau kankinau šį prakeiktą build'ą. Nepadėjo jokie žaidimai su Python'u (įdiegiau v3.3, įvairias komandas į terminalą vedžiau). Tiesa, noriu pabrėžti, kad atsisiųsti senesnių versijų oficialūs build'ai (2.59; 2.69) pasileidžia be problemų. Spėju, kad neoficialus build'as bus kažkaip kitaip sukompiliuotas.
   Galiausiai internete susiieškojau šį nelaimingą failą (libpython3.3m.so.1.0) ir atsisiuntęs įkėliau į /usr/lib aplanką. Dabar vėl pabandžius per terminalą paleisti, išmetė tą patį pranešimą kaip ir anksčiau, bet dabar jau neranda kitokio failo - libOpenColorIO.so.1  >:( .

P.S. Gali būti, kad aš čia nesąmones išdarinėju, nes su Ubuntu esu pažįstamas gal savaitę su trupučiu ir man čia dar labai tamsus miškas.

P.P.S. Windows'ams skirtas neoficialus build'as pasileidžia (bandžiau su pažįstamo Windows 7, o su XP, gyvatė - vėl nepasileidžia).

Kilgoras Trautas

  • Žaliukas
  • *
  • Posts: 30
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #7 on: 2014-07-30, 22:53:47 »
parodyk ką rodo:
# ldd /kelias/iki/blender/paleidžiamo/failo

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #8 on: 2014-07-31, 11:06:49 »
    Nepykit, gaunasi labai ilgas postas:

linux-vdso.so.1 =>  (0x00007fff6fc60000)
   libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f3fd03ff000)
   libpython3.3m.so.1.0 => /usr/lib/x86_64-linux-gnu/libpython3.3m.so.1.0 (0x00007f3fcff8d000)
   libopenal.so.1 => /usr/lib/x86_64-linux-gnu/libopenal.so.1 (0x00007f3fcfd33000)
   libOpenColorIO.so.1 => not found
   libHalf.so.6 => /usr/lib/x86_64-linux-gnu/libHalf.so.6 (0x00007f3fcfaf0000)
   libIlmImf.so.6 => /usr/lib/x86_64-linux-gnu/libIlmImf.so.6 (0x00007f3fcf840000)
   libIex.so.6 => /usr/lib/x86_64-linux-gnu/libIex.so.6 (0x00007f3fcf622000)
   libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f3fcf409000)
   libtiff.so.4 => not found
   libavformat.so.53 => not found
   libavcodec.so.53 => not found
   libswscale.so.2 => /usr/lib/x86_64-linux-gnu/libswscale.so.2 (0x00007f3fcf1c0000)
   libavutil.so.51 => not found
   libavdevice.so.53 => not found
   libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f3fcef57000)
   libfftw3.so.3 => /usr/lib/x86_64-linux-gnu/libfftw3.so.3 (0x00007f3fceb5f000)
   libSDL-1.2.so.0 => /usr/lib/x86_64-linux-gnu/libSDL-1.2.so.0 (0x00007f3fce8c9000)
   libGL.so.1 => /usr/lib/nvidia-304-updates/libGL.so.1 (0x00007f3fce5ab000)
   libGLU.so.1 => /usr/lib/x86_64-linux-gnu/libGLU.so.1 (0x00007f3fce33d000)
   libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f3fce008000)
   libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007f3fcddf7000)
   libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f3fcdbf1000)
   libspnav.so.0 => not found
   libboost_locale.so.1.53.0 => not found
   libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f3fcd99b000)
   libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f3fcd775000)
   libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f3fcd570000)
   libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f3fcd352000)
   libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f3fcd04e000)
   libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f3fccd47000)
   libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f3fcc981000)
   libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f3fcc76b000)
   libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f3fcc567000)
   librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f3fcc35f000)
   libIlmThread.so.6 => /usr/lib/x86_64-linux-gnu/libIlmThread.so.6 (0x00007f3fcc159000)
   libavutil.so.52 => /usr/lib/x86_64-linux-gnu/libavutil.so.52 (0x00007f3fcbf33000)
   libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f3fcbd02000)
   libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f3fcb832000)
   libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f3fcb605000)
   libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f3fcb3fc000)
   libasound.so.2 => /usr/lib/x86_64-linux-gnu/libasound.so.2 (0x00007f3fcb10b000)
   libpulse-simple.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-simple.so.0 (0x00007f3fcaf07000)
   libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f3fcacbe000)
   libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f3fcaaab000)
   libcaca.so.0 => /usr/lib/x86_64-linux-gnu/libcaca.so.0 (0x00007f3fca7de000)
   libnvidia-tls.so.304.117 => /usr/lib/nvidia-304-updates/tls/libnvidia-tls.so.304.117 (0x00007f3fca5db000)
   libnvidia-glcore.so.304.117 => /usr/lib/nvidia-304-updates/libnvidia-glcore.so.304.117 (0x00007f3fc81f0000)
   libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f3fc7fd1000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f3fd06bc000)
   libpulsecommon-4.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-4.0.so (0x00007f3fc7d69000)
   libjson-c.so.2 => /lib/x86_64-linux-gnu/libjson-c.so.2 (0x00007f3fc7b5e000)
   libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f3fc7918000)
   libslang.so.2 => /lib/x86_64-linux-gnu/libslang.so.2 (0x00007f3fc7588000)
   libncursesw.so.5 => /lib/x86_64-linux-gnu/libncursesw.so.5 (0x00007f3fc7354000)
   libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007f3fc712a000)
   libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f3fc6f26000)
   libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f3fc6d20000)
   libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f3fc6b15000)
   libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f3fc690f000)
   libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f3fc66f4000)
   libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f3fc64d9000)


   Neranda, jeigu neapsiskaičiavau, aštuonių failiukų. Gal kokių tvarkyklių trūksta, ar, paprasčiausiai, šias bylas reikės susirankioti po vieną?


« Last Edit: 2014-07-31, 11:34:55 by {Giedrius} »

Kilgoras Trautas

  • Žaliukas
  • *
  • Posts: 30
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #9 on: 2014-07-31, 13:31:14 »
ta blender versija pas tave sistemoje neranda jai reikalingu bendrųjų bibliotekų
   libOpenColorIO.so.1 => not found
   libtiff.so.4 => not found
   libavformat.so.53 => not found
   libavcodec.so.53 => not found
   libavutil.so.51 => not found
   libavdevice.so.53 => not found
   libspnav.so.0 => not found
   libboost_locale.so.1.53.0 => not found
tuomet tau reikia pabandyti instaliuoti šias bibliotekas
$ sudo apt-get install libopencolorio1 libtiff5 libavformat54 libavcodec54 libavutil52 libavdevice53 libspnav0 libboost-locale1.54.0
čia aš pagal ubuntu 14.04 versija parinkau. Kitose sistemose versijos gali skirtis.

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #10 on: 2014-08-01, 13:16:56 »
    Dėkui Kilgorai, kad padedi  :) . Padariau, kaip siūlei. Po to vėl įvedus šią komandą

Code: [Select]
ldd /kelias/iki/blender/paleidžiamo/failo
parodė, kad ne visos bibliotekos sėkmingai įsidiegė. Bus mano žioplio kaltė, nes neparašiau, kad įsidiegiau 64bit OS. Šįkart jas visas nutariau atsisiųsti atskirai iš čia ir pasinaudojęs šia komanda (pvz.):

Code: [Select]
sudo dpkg -i ./libicu48_4.8.1.1-12ubuntu2_amd64.deb
atskirai, po vieną, įdiegiau. Dabar vėl įvedus # ldd ..... daugiau eilučių su "=> not found" nebeliko.
   Po visų šitų vargų į terminalą įvedus /kelias/iki/blender, išmeta štai ką:

connect failed: No such file or directory
found bundled python: /home/***/Atsiuntimai/blender1/2.69/python
Traceback (most recent call last):
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/site.py", line 629, in <module>
    main()
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/site.py", line 614, in main
    known_paths = addusersitepackages(known_paths)
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/site.py", line 284, in addusersitepackages
    user_site = getusersitepackages()
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/site.py", line 260, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/site.py", line 250, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/sysconfig.py", line 610, in get_config_var
    return get_config_vars().get(name)
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/sysconfig.py", line 560, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/sysconfig.py", line 432, in _init_posix
    from _sysconfigdata import build_time_vars
  File "/home/***/Atsiuntimai/blender1/2.69/python/lib/python3.3/_sysconfigdata.py", line 6, in <module>
    from _sysconfigdata_m import *
ImportError: No module named '_sysconfigdata_m'


   Kaip suprantu, šiam build'ui kažkuo neįtinka pas mane esantis python'as, arba netgi (gal) ši Ubuntu versija. Ir šiaip, ši OS, pas mane kažkaip nelabai "eina" - normaliai neišsijungia PC. Pasirinkus "Išjungti"  po kiek laiko atsiranda "Ubuntu" užrašas su apačioje progresą rodančiais taškais ir daugiau nieko nevyksta, tuomet reikia ilgai laikyti nuspaustą PWR mygtuką, kad galutinai išsijungtų. Gal mano "geležis" šiai OS netinka, gal įsidiegti sensnę Ubuntu?

P.S O jūs, kuris nors, bandėt pas save šią neoficialią Blender versiją pasileisti? Normaliai pasileidžia?

« Last Edit: 2014-08-01, 13:22:39 by {Giedrius} »

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #11 on: 2014-08-02, 20:53:38 »
   Pagaliau paleidau tą nelaimingą neoficialų Blender'į. Pagrindine šios problemos išsprendimo priežastimi tapo senesnės OS (Ubuntu 13) įdiegimas. Aišku ir čia reikėjo atsisiųsti ir įdiegti panašų kiekį papildomų bibliotekų, bet šįkart jos įsirašė be problemų. Tiesa, liko anksčiau minėta problema, susijusi su normaliu kompiuterio išjungimu (restart'uoja normaliai). Bandysiu ieškoti sprendimo būdų. Jei nepavyks - ne bėda, kadangi visa šitai yra laikina (gal  :) ). Taip darau dėl to, jog šis neoficialaus ir oficialus 2.71v Blender'is jau nepalaiko Windows XP. Ateity, priklausomai nuo aplinkybių, atnaujinsiu šią, arba komplektuosiu naują dėžę, kurioje bus 64bit legalūs Windows 7. Nors ką gali žinoti - galbūt, kaip ir dabar, šalia Windows'ų bus ir Ubuntu.

P.S. Dėkui už atsakymus, nes jei ne jie, tai turbūt iki šiolei būčiau ratais vaikščiojęs - stumtelėjot reikiama kryptimi.
« Last Edit: 2014-08-02, 23:03:37 by {Giedrius} »

{Giedrius}

  • Jaunuolis
  • **
  • Posts: 78
Re: Dveji skirtingų versijų Blender'iai Ubuntu OS
« Reply #12 on: 2014-08-04, 12:40:37 »
   Berods išsprendžiau ir su kompiuterio išsijungimu susijusią problemą. Mano atveju padėjo šis VARIANTAS.